Pozycja Technorati Wtyczka WordPress w wersji 2 została wydana!

Wkrótce po pierwszej wtyczce Technorati Rank, przeprojektowałem zawartość wyjściową, aby to zrobić CSS napędzane (poniżej zrzut ekranu, możesz wchodzić w interakcję z tym na pasku bocznym mojej witryny):

Ranking Technorati Wtyczka WordPress w wersji 2

Ten był nieco trudniejszy do wyprodukowania, ale wynik jest o wiele ładniejszy. Po pierwsze, wykorzystałem to, czego się nauczyłem Bittbox aby utworzyć każdy z przycisków wyjściowych na obrazie w programie Illustrator.

Następnym krokiem było wykorzystanie stylów, aby faktycznie zbudować kogoś o mapa obrazu poza tym, że faktycznie jest bez mapy! Właściwie to całkiem fajne. Możesz ustawić ogólne tło div, a następnie utworzyć każdy z „hotspotów”, wykorzystując pozycjonowanie bezwzględne i CSS. Wyświetl wynikowy plik CSS.

Dodałem również link do nowego Technorati WTF stronę i adres RSS witryny. Mam nadzieję, że to lubisz! Myślę, że to ogromna poprawa w stosunku do pierwszej wersji! Jest i link w prawym dolnym rogu, który również promuje wtyczkę.

Obecny ranking Technorati Wtyczka WordPress w wersji 2.0.4

Komentarze 23

  1. 1
    • 2

      To na pewno! Od dłuższego czasu szukałem pomocy w programie Illustrator. Nie używam go wystarczająco, aby być w tym fantastycznym, więc strona taka jak Bittbox oszczędza mi dużo czasu!

  2. 3

    Próbowałem zainstalować najnowsze i najlepsze, postępując zgodnie ze wskazówkami co do „litery” 🙂

    ale otrzymałem następujący błąd

    Błąd krytyczny: nie można utworzyć instancji nieistniejącej klasy: simplexmlelement w /home/winex4/public_html/wp-content/plugins/technorati-rank/technorati-rank.php w wierszu 64

    jakieś sugestie?

    • 4
      • 5
        • 6

          Mam nadzieję, że tak! Ale mam też nadzieję, że twoje aktualizacje hosta. PHP5 naprawdę oferuje znacznie lepsze ulepszenia wydajności, a także lepsze narzędzia do korzystania z interfejsów API. Używam Jumpline, zobaczysz link na mojej liście sponsorów na mojej stronie głównej. Uważam również, że Dotster ma dobry hosting VDS z najnowszymi i najlepszymi.

      • 7

        Doug,
        Mam ten sam problem
        Zadzwoniłem do mojego hosta i powiedzieli, że mój serwer ma PHP 4 i PHP 5, ale jeśli chcę uruchomić plik przy użyciu PHP 5, skrypt musi mieć rozszerzenie pliku .php5.

        Więc… Zmieniłem rozszerzenia plików i znikają one z wtyczek w wordpressie.

        Jakieś pomysły?

  3. 10

    Niesamowita wtyczka, doskonała stylizacja! Dzięki Doug i świetna robota. Nigdy nie wiedziałem o pierwszym z nich, ale to jest natychmiast na moim pasku bocznym.

    NAPRAWDĘ satysfakcjonujące jest to, że moje wskazówki dotyczące programu Illustrator pomogły Ci w tworzeniu przycisków !!!!!

    dzięki jeszcze raz,

    ~ BittBox

    • 11

      Dziękuję, BittBox! Myślę, że mam dobre wyczucie stylu, ale przez większość czasu nigdy nie udawało mi się to dobrze. Fakt, że możesz pobrać próbki i przeanalizować je, robi różnicę. Teraz jestem w stanie zrealizować te pomysły. 🙂

      Następnie bawię się przemyśleniami na temat nagłówka i tła mojego bloga.

  4. 12

    Cóż, Doug, wygląda na to, że wtyczka w wersji 2 mnie nienawidzi. Otrzymuję komunikaty o błędach:

    Warning: fopen(/technorati-rank.html) [function.fopen]: failed to open stream: Permission denied in /..../wp-content/plugins/technorati-rank/technorati-rank.php on line 121
    Warning: fwrite(): supplied argument is not a valid stream resource in /..../wp-content/plugins/technorati-rank/technorati-rank.php on line 122
    Warning: fclose(): supplied argument is not a valid stream resource in /..../wp-content/plugins/technorati-rank/technorati-rank.php on line 123

    Pomimo komunikatów o błędach pokazuje również mój ranking Technorati (~ 26.5k: D). Nie mam wystarczającej wiedzy na temat PHP, aby wiedzieć, dlaczego płacze nad tym jednym plikiem.
    Co ciekawe, na naszym serwerze używamy SuPHP, więc wszystko działa tak jak my (więc wymagania chmod nie wymagają już plików z możliwością zapisu przez świat, a skrypty php nie będą wykonywane, jeśli na przykład chmod jest zbyt wysoki).

    Wszystkie pliki php dla tej subdomeny działają jako php5.

    Jakieś pomysły?

    • 13

      Czy masz katalog wp-content / cache Xial? Pomyślałem, że dobrym pomysłem byłoby wykorzystanie tego samego katalogu pamięci podręcznej, co WP-Cache. Z perspektywy czasu może to nie był dobry pomysł! Ta linia jest zdecydowanie do zapisu w pliku pamięci podręcznej.

      • 14

        Z pewnością tak, Doug. Używam WP-Cache od dłuższego czasu. 🙂

        Byłem też trochę ciekawy, dlaczego narzekał na to, skoro mam niezbędny katalog, ale myślę, że to coś zupełnie innego.

      • 15

        Ciekawe informacje do dodania:

        $ pwd
        /..../wp-content/cache
        $ ls -l tech*
        -rw-r--r-- 1 meeeeeeee meeeeeeee 1.1K Mar 12 11:47 technorati-rank.html

        Nadal zwraca błędy.

    • 16

      Po prostu chcę zadzwonić z tym samym błędem. Witryna uruchamia php5 i wyświetla się przycisk.
      Próbowałem skomentować wiersze 121-123 i wtyczka działa dobrze. Czy mogę umieścić to na żywo, czy brak tych linii spowoduje problemy na dłuższą metę?

  5. 17

    Otrzymuję te same błędy, co powyżej, myślałem, że to mój katalog pamięci podręcznej, ale mam jeden i upewniłem się, że prawa zapisu są poprawne.
    Na pasku bocznym pokaże wtyczkę (z rangą), ale z tymi błędami nad nią.

    • 18

      Cześć Richard,

      Czy możesz sprawdzić, czy masz wersję PHP 5+ i włączoną CURL? Możesz to zrobić, tworząc stronę w swojej witrynie z rozszerzeniem <?php phpinfo(); ?> na stronie. Następnie otwórz tę stronę. Na górze strony będzie znajdować się Twoja wersja PHP i możesz wyszukać CURL, aby upewnić się, że jest włączona.

      Dzięki!
      Doug

      • 19

        Cóż, Doug, dwukrotnie sprawdziłem moją wersję PHP.
        Używam PHP5 i cURL jest wkompilowany (jedno z moich zwykłych trzech żądań do mojego hosta, aby coś skompilować do PHP).

        Wszystko inne działa dobrze, ale nie jestem do końca pewien, dlaczego ta wtyczka się dławi, chyba że jest to wersja cURL wkompilowana w PHP (mamy 7.15.4, a najnowsza wygląda na 7.16.1). Jednak nie chcę nękać mojego hosta, aby ponownie skompilował php5 tylko po to, jeśli mogę na to poradzić. <: 3

        • 20

          W ten weekend przyjrzę się dokładniej. Działa bez żadnych problemów na kilku witrynach - więc jest to jedna z 3 rzeczy: 1. Pamięć podręczna, 2. cURL lub 3. Wersja PHP.

          Mogę wykorzystać starszą funkcjonalność PHP 4 do ściągnięcia i parsowania XML, ale może to spowolnić trochę - mam zamiar przetestować w ten weekend. Doceniam cały wkład. "Houston, mamy problem!".

  6. 21

    Uwaga: firma Technorati uruchomiła plik Władza Podłącz.

    Również - dla wszystkich, którzy mają problemy z tą wtyczką, gorąco zachęcam do przeniesienia się na nowego hosta :). Mam 12-miesięczną bezpłatną ofertę specjalną z moim gospodarzem na dole mojego O nas strona.

  7. 22
  8. 23

    Otrzymałem wiele próśb, że wystąpiły błędy podczas zapisywania lub odczytywania z pliku pamięci podręcznej. W rzeczywistości zidentyfikowałem problem polegający na tym, że wypychałem i wyciągałem plik pamięci podręcznej do katalogu głównego. Zmodyfikowałem wersję 2.0.4 tak, aby zapisywała do podkatalogu pamięci podręcznej w katalogu wtyczki.

    Daj mi znać, jak to działa! (Nadal potrzebuje SimpleXML i cURL!)

Co o tym myślisz?

Ta strona używa Akismet do redukcji spamu. Dowiedz się, jak przetwarzane są dane komentarza.